Sitecore – RebuildSearchIndex|System.FormatException: Unrecognized Guid format.

After upgrading from 7.5.141003 to 7.5.150130, when I tried to rebuild the search index or the Link database I got the System.FormatException: Unrecognized Guid format after sometime!

Uli (@UliWeltersbach) had already written a great blog post about this exception and how to find the items causing the issue and how to fix the issue.

I would recommend you read Uli’s blog, but here is the quick version – The exception is caused by an error in the _tracking field used by the Analytic’s engine, which is very strange as the website has disabled the Analytic’s, see below?

disabled

Analytics is disabled, so why when I try to save the item to I get the following exception???

cant save

As I am not a very trusting person, I swapped to using raw values in the content editor and I could see that there was in fact data in the __tracking field!

raw

Cause

Initially the website did have analytics enabled I guess, but as some point it was disabled. The site was upgraded from 6.4 to 7.5 and somewhere along the line one or more of the update packages form sitecore did not update the __tracking field as analytics was disabled.

Therefore the old contents in the __tracking file were not in the correct format and caused the exception.

Solution

In my case deleting the contents was enough to fix the issue.

Another approach is to enable analytics edit the tracking field and save again, and it is converted to the correct format.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s